Logo de ce site

Accueil > GnuLinux Debian/Ubuntu > apt ne fonctionne pas

apt ne fonctionne pas

lundi 3 février 2014

Message d’erreur :
’E:Erreur de lecture - read (5 : Erreur d’entrée/sortie), E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.’

sudo rm /var/lib/apt/lists/lock
sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
sudo rm /var/cache/apt/*.bin
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get update
sudo dpkg --clear-avail
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get dist-upgrade

Erreur :
E : Encountered a section with no Package : header
E : Problem with MergeList /var/lib/apt/lists/fr.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
E : Impossible d’ouvrir ou d’analyser le fichier contenant la liste des états ou celui des paquets disponibles.
E : _cache->open() failed, please report.

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

La suite sur http://doc.ubuntu-fr.org/probleme_apt et http://forum.ubuntu-fr.org/viewtopic.php?id=291139